[pmapper-users] how to add google satellite imagery layer in pmapper 4.3.2

classic Classic list List threaded Threaded
18 messages Options
h
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[pmapper-users] how to add google satellite imagery layer in pmapper 4.3.2

h
Kindly provide details regarding adding a google satellite imagery/map layer in pmapper 4.3.2 based

application ? .

 
------------------------------------------------------------------------------
_______________________________________________
pmapper-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/pmapper-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [pmapper-users] how to add google satellite imagery layer in pmapper 4.3.2

gioza
Have a look to this:

http://www.gdal.org/frmt_wms_googlemaps_tms.xml

save the xml in your data directory (where your shapefiles are).

I think you have to add epsg 900913 or 3753 in your projections files.

In your mapfile create a layer:

LAYER
    NAME "gdal"
    STATUS OFF
    TYPE RASTER
    DATA "frmt_wms_googlemaps_tms.xml" #NAME OF XML FILE!!!
         PROCESSING "OVERSAMPLE_RATIO=1"
    PROJECTION
      "init=EPSG:900913"
    END

END

add in your config.xml gdal (or the name you want) layer

in this way google maps work in pmapper4 but I prefer pmapper5

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [pmapper-users] how to add google satellite imagery layer in pmapper 4.3.2

jose mvm
Hi Giovanni,

It works through the pmapper 4!
But it works only until the scale 750. For higher scales, like 1:500, the parameter

PROCESSING "BANDS=1"

is required... so the image only appears in black & white mode.

Any clue?

Thanks
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [pmapper-users] how to add google satellite imagery layer in pmapper 4.3.2

gioza
Hi,

first of all pay attention to GOOGLE MAPS TERMS OF USE. In the way above illustrated the "attributions" doesn't appear on the map and I think it is mandatory to use them.

By the way, scale limitation is probably due to google maps service. Try to check the max scale directly in google maps...even in qgis the service has scale limitation
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [pmapper-users] how to add google satellite imagery layer in pmapper 4.3.2

jose mvm
Thanks

in qgis the service has (no) scale limitation!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [pmapper-users] how to add google satellite imagery layer in pmapper 4.3.2

Bruno Moreira
In reply to this post by gioza
Hi,

I've tried this in a new installation of pMapper 4.3.2, but I've not succeed:

what have I done?
1 - edited config_default.xml and added group gdal to it (also added projection 900913 I found somewhere, after tried without it, but result was the same)
2 - added frmt_wms_googlemaps_tms.xml to pmapper_data folder
3 - editted pmapper_demo.map and added Layer info to it

but I get this error:
Warning: ms_newMapObj(): [MapServer Error]: msProcessProjection(): no options found in 'init' file in C:\ms4w\apps\pmapper\pmapper-4.3.2\incphp\globals.php on line 66

Fatal error: Uncaught exception 'MapScriptException' with message 'Failed to open map file "C:/ms4w/apps/pmapper/pmapper-4.3.2/config/default/pmapper_demo.map"' in C:\ms4w\apps\pmapper\pmapper-4.3.2\incphp\globals.php:66 Stack trace: #0 C:\ms4w\apps\pmapper\pmapper-4.3.2\incphp\globals.php(66): ms_newMapObj('C:/ms4w/apps/pm...') #1 C:\ms4w\apps\pmapper\pmapper-4.3.2\map_default.phtml(43): require_once('C:\ms4w\apps\pm...') #2 {main} thrown in C:\ms4w\apps\pmapper\pmapper-4.3.2\incphp\globals.php on line 66

whe am I doing wrong?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[pmapper-users] Σχετ: how to add google satellite imagery layer in pmapper 4.3.2

Andreas Douvalis
Add to the C:\ms4w\proj\nad\epsg file the following lines:

# Google Maps Spherical Mercator
<900913> +proj=merc +lon_0=0 +k=1 +x_0=0 +y_0=0 +a=6378137 +b=6378137 +towgs84=0,0,0,0,0,0,0 +units=m +no_defs

    Στις 1:27 μ.μ. Δευτέρα, 25 Ιανουαρίου 2016, ο/η Bruno Moreira <[hidden email]> έγραψε:
 

 Hi,

I've tried this in a new installation of pMapper 4.3.2, but I've not
succeed:

what have I done?
1 - edited  config_default.xml
<http://pmapper-users-p-mapper-users-mailing-list.993774.n3.nabble.com/file/n4025830/config_default.xml
and added group gdal to it (also added projection 900913 I found somewhere,
after tried without it, but result was the same)
2 - added  frmt_wms_googlemaps_tms.xml
<http://pmapper-users-p-mapper-users-mailing-list.993774.n3.nabble.com/file/n4025830/frmt_wms_googlemaps_tms.xml
to pmapper_data folder
3 - editted  pmapper_demo.map
<http://pmapper-users-p-mapper-users-mailing-list.993774.n3.nabble.com/file/n4025830/pmapper_demo.map
and added Layer info to it

but I get this error:
Warning: ms_newMapObj(): [MapServer Error]: msProcessProjection(): no
options found in 'init' file in
C:\ms4w\apps\pmapper\pmapper-4.3.2\incphp\globals.php on line 66

Fatal error: Uncaught exception 'MapScriptException' with message 'Failed to
open map file
"C:/ms4w/apps/pmapper/pmapper-4.3.2/config/default/pmapper_demo.map"' in
C:\ms4w\apps\pmapper\pmapper-4.3.2\incphp\globals.php:66 Stack trace: #0
C:\ms4w\apps\pmapper\pmapper-4.3.2\incphp\globals.php(66):
ms_newMapObj('C:/ms4w/apps/pm...') #1
C:\ms4w\apps\pmapper\pmapper-4.3.2\map_default.phtml(43):
require_once('C:\ms4w\apps\pm...') #2 {main} thrown in
C:\ms4w\apps\pmapper\pmapper-4.3.2\incphp\globals.php on line 66

whe am I doing wrong?




--
View this message in context: http://pmapper-users-p-mapper-users-mailing-list.993774.n3.nabble.com/pmapper-users-how-to-add-google-satellite-imagery-layer-in-pmapper-4-3-2-tp4025815p4025830.html
Sent from the pmapper-users -- p.mapper users mailing list mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=267308311&iu=/4140
_______________________________________________
pmapper-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/pmapper-users


 
------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=267308311&iu=/4140
_______________________________________________
pmapper-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/pmapper-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[pmapper-users] Σχετ: Σχετ: how to add google satellite imagery layer in pmapper 4.3.2

Andreas Douvalis

Sometimes there is conflict regarding the path of proj folder. Try to check environment variables for PROJ_LIB. Moreover add to your mapfile the line below:

CONFIG "PROJ_LIB" "/ms4w/proj/"

    Στις 11:25 μ.μ. Δευτέρα, 25 Ιανουαρίου 2016, ο/η Andreas Douvalis <[hidden email]> έγραψε:
 

 Add to the C:\ms4w\proj\nad\epsg file the following lines:

# Google Maps Spherical Mercator
<900913> +proj=merc +lon_0=0 +k=1 +x_0=0 +y_0=0 +a=6378137 +b=6378137 +towgs84=0,0,0,0,0,0,0 +units=m +no_defs

    Στις 1:27 μ.μ. Δευτέρα, 25 Ιανουαρίου 2016, ο/η Bruno Moreira <[hidden email]> έγραψε:
 

 Hi,

I've tried this in a new installation of pMapper 4.3.2, but I've not
succeed:

what have I done?
1 - edited  config_default.xml
<http://pmapper-users-p-mapper-users-mailing-list.993774.n3.nabble.com/file/n4025830/config_default.xml
and added group gdal to it (also added projection 900913 I found somewhere,
after tried without it, but result was the same)
2 - added  frmt_wms_googlemaps_tms.xml
<http://pmapper-users-p-mapper-users-mailing-list.993774.n3.nabble.com/file/n4025830/frmt_wms_googlemaps_tms.xml
to pmapper_data folder
3 - editted  pmapper_demo.map
<http://pmapper-users-p-mapper-users-mailing-list.993774.n3.nabble.com/file/n4025830/pmapper_demo.map
and added Layer info to it

but I get this error:
Warning: ms_newMapObj(): [MapServer Error]: msProcessProjection(): no
options found in 'init' file in
C:\ms4w\apps\pmapper\pmapper-4.3.2\incphp\globals.php on line 66

Fatal error: Uncaught exception 'MapScriptException' with message 'Failed to
open map file
"C:/ms4w/apps/pmapper/pmapper-4.3.2/config/default/pmapper_demo.map"' in
C:\ms4w\apps\pmapper\pmapper-4.3.2\incphp\globals.php:66 Stack trace: #0
C:\ms4w\apps\pmapper\pmapper-4.3.2\incphp\globals.php(66):
ms_newMapObj('C:/ms4w/apps/pm...') #1
C:\ms4w\apps\pmapper\pmapper-4.3.2\map_default.phtml(43):
require_once('C:\ms4w\apps\pm...') #2 {main} thrown in
C:\ms4w\apps\pmapper\pmapper-4.3.2\incphp\globals.php on line 66

whe am I doing wrong?




--
View this message in context: http://pmapper-users-p-mapper-users-mailing-list.993774.n3.nabble.com/pmapper-users-how-to-add-google-satellite-imagery-layer-in-pmapper-4-3-2-tp4025815p4025830.html
Sent from the pmapper-users -- p.mapper users mailing list mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=267308311&iu=/4140
_______________________________________________
pmapper-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/pmapper-users


 
------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=267308311&iu=/4140
_______________________________________________
pmapper-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/pmapper-users


 
------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=267308311&iu=/4140
_______________________________________________
pmapper-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/pmapper-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [pmapper-users] Σχετ: Σχετ: how to add google satellite imagery layer in pmapper 4.3.2

Bruno Moreira
First of all, thank you for the fast reply

I've tried what you said and this was the result:
- added epsg google data to c:\ms4w\proj\nad\epsg file, and now pMapper opens with Loading sign, and google layer at TOC table, but no map appear but a black screen
- tried to add CONFIG "PROJ_LIB" "/ms4w/proj/" to map file, but it gave me an error
- created a PROJ_LIB system env variable, no error, but the result was the same

I've checked the apache error.log:
[Tue Jan 26 10:09:17 2016] [error] [client 192.168.7.14] PHP Warning:  mapObj::draw(): [MapServer Error]: msDrawMap(): Failed to draw layer named 'gdal'., referer: http://cmsc0404/pmapper/map_default.phtml?config=localizacoes
[Tue Jan 26 10:09:17 2016] [error] [client 192.168.7.14]  in C:\\ms4w\\apps\\pmapper\\pmapper-4.3.2\\incphp\\map\\map.php on line 336, referer: http://cmsc0404/pmapper/map_default.phtml?config=localizacoes
[Tue Jan 26 10:09:17 2016] [error] [client 192.168.7.14] PHP Warning:  mapObj::draw(): [MapServer Error]: drawGDAL(): GDALDatasetRasterIO() failed: C:/ms4w/apps/pmapper/pmapper-4.3.2/config/localizacoes/../../../pmapper_demodata/google_maps_wms.xml, band 1: IReadBlock failed at X offset 971, Y offset 790, referer: http://cmsc0404/pmapper/map_default.phtml?config=localizacoes
[Tue Jan 26 10:09:17 2016] [error] [client 192.168.7.14]  in C:\\ms4w\\apps\\pmapper\\pmapper-4.3.2\\incphp\\map\\map.php on line 336, referer: http://cmsc0404/pmapper/map_default.phtml?config=localizacoes
[Tue Jan 26 10:09:17 2016] [error] [client 192.168.7.14] PHP Fatal error:  Call to a member function saveImage() on a non-object in C:\\ms4w\\apps\\pmapper\\pmapper-4.3.2\\incphp\\common.php on line 309, referer: http://cmsc0404/pmapper/map_default.phtml?config=localizacoes

Looks like  IReadBlock failed at X offset 971, Y offset 790 is the problem, any clue?

Thank you
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [pmapper-users] Σχετ: Σχετ: how to add google satellite imagery layer in pmapper 4.3.2

Bruno Moreira
Hi!

the problem was in google_maps_wms.xml

changed:
   from: ServerUrl>http://mt.google.com/vt/lyrs=m&x=${x}&y=${y}&z=${z}</ServerUrl>
   to: <ServerUrl>http://mt.google.com/vt/lyrs=m&x=${x}&y=${y}&z=${z}</ServerUrl>

now everything works well :)

once again, thank you
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [pmapper-users] Σχετ: Σχετ: how to add google satellite imagery layer in pmapper 4.3.2

Bruno Moreira
This post was updated on .
My last post seemed odd, because I didn't use RAW text
changed: 
   from: ServerUrl>http://mt.google.com/vt/lyrs=m&x=${x}&y=${y}&z=${z}</ServerUrl>
   to: <ServerUrl>http://mt.google.com/vt/lyrs=m&amp;x=${x}&amp;y=${y}&amp;z=${z}</ServerUrl>

also had to use <Projection>EPSG:3857</Projection> instead of 900913

everything is working fine on all maps(maps, hybrid, satellite, etc...)

Thank you once again
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [pmapper-users] Σχετ: Σχετ: how to add google satellite imagery layer in pmapper 4.3.2

Tommaso Vinciguerra
It works for me, but map view has quite blurry fonts (satellite has a good
resolution instead). Does it depend on the wms or on mapserver map file
configuration ?
Tom

2016-01-26 13:36 GMT+01:00 Bruno Moreira <[hidden email]>:

> My last post seemed odd, because I didn't use RAW text
>
>
> also add to use <Projection>EPSG:3857</Projection> instead of 900913
>
> everything is working fine on all maps(maps, hybrid, satellite, etc...)
>
> Thank you once again
>
>
>
> --
> View this message in context:
> http://pmapper-users-p-mapper-users-mailing-list.993774.n3.nabble.com/pmapper-users-how-to-add-google-satellite-imagery-layer-in-pmapper-4-3-2-tp4025815p4025836.html
> Sent from the pmapper-users -- p.mapper users mailing list mailing list
> archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> Site24x7 APM Insight: Get Deep Visibility into Application Performance
> APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
> Monitor end-to-end web transactions and take corrective actions now
> Troubleshoot faster and improve end-user experience. Signup Now!
> http://pubads.g.doubleclick.net/gampad/clk?id=267308311&iu=/4140
> _______________________________________________
> pmapper-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/pmapper-users
>
------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=267308311&iu=/4140
_______________________________________________
pmapper-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/pmapper-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [pmapper-users] Σχετ: Σχετ: how to add google satellite imagery layer in pmapper 4.3.2

Bruno Moreira
We're experiencing the same issue, no clues about how to sort it out until now.

Help would be appreciated
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [pmapper-users] Σχετ: Σχετ: how to add google satellite imagery layer in pmapper 4.3.2

jose mvm
Running MapServer version 6.4.1?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [pmapper-users] Σχετ: Σχετ: how to add google satellite imagery layer in pmapper 4.3.2

Bruno Moreira
I installed MS4W 3.0.6

Contents
========
The following are included in the base package:
- Apache version 2.2.22
- PHP version 5.4.3
- MapServer 6.0.3 CGI and MapScript (CSharp, Java, PHP,
  Python)
- GDAL 1.9.1
- mapserver utilities
- gdal/ogr utilities
- proj.4 utilities
- shp2tile utility
- shapelib utilities
- shpdiff utility
- avce00 utilities
- PHP_OGR Extension 1.1.1
- OWTChart 1.2.0
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [pmapper-users] Σχετ: Σχετ: how to add google satellite imagery layer in pmapper 4.3.2

jose mvm
probably due to the mapserver release...
my installation is running on linux
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [pmapper-users] Σχετ: Σχετ: how to add google satellite imagery layer in pmapper 4.3.2

gioza
In reply to this post by Tommaso Vinciguerra
probably it is due to mapfile setting. Try to modify OVERSAMPLE_RATIO
in my opinion the way out is absolutely PMAPPER5
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [pmapper-users] Σχετ: Σχετ: how to add google satellite imagery layer in pmapper 4.3.2

jose mvm
or try another special processing parameters:
http://mapserver.org/input/raster.html

but it's works fine in pmapper 4 too!
Loading...